Como atualizar a versão PHP do WordPress quando aparece uma mensagem de versão insegura do PHP

Evitar problemas de incompatibilidade entre WordPress e PHP requer planejamento, manutenção proativa e atenção aos detalhes. Veja aqui como alterar a versão PHP no caso de incompatibilidade com Wordpress

Não quebre a cabeça tentando criar seu site sozinho. Criamos para você!
Não quebre a cabeça tentando criar seu site sozinho

Neste post vamos ver como atualizar a versão PHP quando aparecer uma mensagem de versão insegura no seu wordpress.

O WordPress é indiscutivelmente uma das plataformas mais populares para criação de sites profissionais e blogs hoje em dia, e seu funcionamento depende intimamente da linguagem de programação PHP.

Se o seu WordPresss está mostrando uma mensagem semelhante a mensagem abaixo, você precisa alterar a versão do seu PHP.

Isso geralmente acontece porque o servidor de hospedagem WordPress possui uma versão ultrapassada ou incompatível com a atual versão do WordPress.

Mas não se preocupe, isso é muito simples de ser corrigido e vou mostrar para você como fazer isso.

[toc]

Atualizar a versão PHP em Hospedagem com Cpanel, veja como

Como atualizar a versão PHP

Se a hospedagem do WordPress utilizar o cpanel como painel é muito simples ajustar a versão do php.

Primeiro você deve logar no seu cpanel, claro! Em seguida você deve ir até a sessão Software.

Você deve ir clicar em Gerenciador de multiphp.

Agora você seleciona o domínio que deseja atualizar a versão do php. Selecione a versão mais recente do seu php e clique em aplicar. No exemplo abaixo a versão mais recente é a 7.3.

Pronto. Agora sua versão do php já está atualizada e o Wordpress com certeza estará mais seguro.

Alterando a versão do PHP em Hospedagem com Cpanel da Hostgator

Dependendo da sua hospedagem a alteração do php pode acontecer de forma diferente. A Hospedagem cpanel da Hostgator tem alguns recursos um pouco diferentes e a forma de mudar a versão do php também é diferente.

Após fazer login no Cpanel você deve ir até a sessão SOFTWARE. Em seguida você deve clicar em PHP SELECTOR

Clique em PUBLIC_HTML, e depois selecione a versão mais recente do php e clique em atualização.

Pronto. Sua instalação WordPress não terá mais problemas com a versão do PHP na Hospedagem de sites da Hostgator

Este tutorial é para hospedagens com o painel de controle chamado Cpanel e talvez sua hospedagem utilize um outro painel. Se for assim, você deve entrar em contato com seu provedor de hospedagem e solicitar instruções de como atualizar sua versão do php.

Como evitar problemas de incompatibilidade entre o WordPress e a versão do PHP

Com atualizações frequentes tanto do WordPress quanto do PHP, problemas de incompatibilidade podem surgir, resultando em erros e mau funcionamento do site.

Para evitar esses problemas e manter seu site WordPress rodando sem interrupções, é essencial seguir algumas práticas recomendadas. Vamos explorar algumas delas:

1. Manter o WordPress e os Plugins Atualizados

Manter tanto o core do WordPress quanto os plugins atualizados é crucial para evitar problemas de incompatibilidade com versões mais recentes do PHP.

As atualizações frequentemente incluem correções de bugs e melhorias de compatibilidade que garantem que seu site funcione corretamente nas versões mais recentes do PHP.

2. Verificar Compatibilidade Antes de Atualizar a versão PHP

Antes de atualizar a versão PHP no seu servidor, verifique se a versão do WordPress e dos plugins instalados são compatíveis com essa nova versão.

O WordPress geralmente fornece informações sobre a compatibilidade com versões específicas do PHP em suas notas de versão.

Plugins essenciais também devem ser verificados quanto à compatibilidade.

3. Usar um Ambiente de Desenvolvimento para Testes

Antes de aplicar atualizações em um ambiente de produção, é altamente recomendável testar todas as atualizações em um ambiente de desenvolvimento ou staging.

Isso permite identificar problemas de incompatibilidade antes que eles afetem o site ao vivo, dando a oportunidade de corrigi-los ou encontrar alternativas antes de comprometer o funcionamento do site principal.

4. Monitorar Logs de Erro e Mensagens de Depreciação

Ao atualizar o PHP ou o WordPress, monitore os logs de erro e mensagens de depreciação. Essas informações podem fornecer pistas valiosas sobre problemas de compatibilidade que precisam ser resolvidos.

Corrigir esses problemas rapidamente pode prevenir maiores complicações.

5. Escolher Plugins e Temas de Fontes Confiáveis

Ao selecionar plugins e temas para o seu site WordPress, escolha aqueles que são desenvolvidos e mantidos por fontes confiáveis.

Plugins desatualizados ou mal mantidos podem não ser compatíveis com versões mais recentes do PHP, levando a problemas de incompatibilidade.

6. Implementar Boas Práticas de Desenvolvimento

Ao desenvolver ou personalizar temas e plugins para o WordPress, adote boas práticas de desenvolvimento de software. Isso inclui seguir as diretrizes do WordPress, evitar funções obsoletas do PHP e manter o código limpo e eficiente para facilitar futuras atualizações.

Conclusão

Evitar problemas de incompatibilidade entre WordPress e PHP requer planejamento, manutenção proativa e atenção aos detalhes.

Com as práticas certas, você pode garantir que seu site WordPress permaneça estável e funcional, mesmo com as atualizações frequentes de PHP e WordPress.

Mantenha-se informado sobre as versões mais recentes, teste antes de implementar mudanças em produção e esteja preparado para ajustar conforme necessário.

Dessa forma, você poderá aproveitar ao máximo as capacidades do WordPress enquanto minimiza problemas técnicos.

5 comentários em “Como atualizar a versão PHP do WordPress quando aparece uma mensagem de versão insegura do PHP”

  1. Não consegui.Não tenho essa opção do cpainel.
    Há outra forma de fazer sem ser pelo cpainel ou apenas em um site específico que aprece esssa mensagem?

Deixe um comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

+ 78 = 86

Rolar para cima